Investigating Delays in Email Delivery (Brevo)

Incident Report for evenito

Resolved

The issue has now been resolved and all emails have been sent out.
We sincerely apologize for any delays you may have experienced recently.
Thank you for your patience and understanding!
If you have any further questions or concerns, please feel free to reach out to our Customer Success Team (help@evenito.com).
Posted Feb 23, 2026 - 17:53 CET

Investigating

We are currently investigating an issue with our third-party email service provider Brevo, that is causing delays in the delivery of some emails for clients utilizing this service.
This issue is specific to clients sending emails via Brevo and does not impact other email delivery methods.
Our technical teams are actively monitoring the situation and we will provide further updates as soon as more information becomes available.
Thank you for your understanding.
Posted Feb 23, 2026 - 16:48 CET
This incident affected: app.evenito.com (E-Mails).