Investigating Potential Delays in Email Delivery and Tracking (Brevo)

Incident Report for evenito

Resolved

This incident has been resolved.
Posted Apr 14, 2025 - 17:31 CEST

Update

We have been informed by our subprocessor, Brevo, that a resolution has been implemented by their technical team, and the processing of transactional emails has restarted.
We are currently monitoring the system closely to ensure the stability of this service. Further updates will be provided as the situation progresses.
Posted Apr 14, 2025 - 14:14 CEST

Update

Brevo is diligently working on resolving the issue. Currently, there are no new updates.
We are closely monitoring the situation and will share any new information as soon as it becomes available.
We appreciate your patience and understanding.
Posted Apr 14, 2025 - 13:08 CEST

Update

Brevo is actively working to resolve the issue. At this moment, there are no new updates.
We continue to monitor the situation closely and will provide further updates as soon as more information becomes available.
Thank you for your patience and understanding.
Posted Apr 14, 2025 - 12:01 CEST

Update

Brevo is still working on resolving the issue, and the team is actively taking steps to mitigate its impact. At this moment, there are no new updates.
We continue to monitor the situation closely and will provide further updates as soon as more information becomes available. Thank you for your patience and understanding.
Posted Apr 14, 2025 - 10:30 CEST

Monitoring

We are currently investigating a potential issue with our third-party email service provider Brevo, that may be causing delays in the delivery of some emails for clients utilizing this service. Additionally, we have observed that the tracking of email bounces and delivery states may be temporarily unavailable for these users.
Our technical teams are actively monitoring the situation to ensure the stability and reliability of email services for affected clients. We understand the importance of timely email communication and are committed to resolving this as quickly as possible.
This issue is specific to clients sending emails via Brevo and does not impact other email delivery methods.
We will provide further updates as soon as more information becomes available. Thank you for your understanding.
Posted Apr 14, 2025 - 08:48 CEST
This incident affected: app.evenito.com (E-Mails).